Przejdź to tekstu

Problem z dostępem do konsoli na sterach binarnych Nvidia

Kategoria: FAQ, etykiety: sprzęt, system

Dodany przez: Huk, 2010-02-05 12:31 (zmodyfikowany: 2010-02-06 19:55)

Wyświetleń: 5598

Tekst pisany dla Debian Testing (aktualnie Squeeze) 05-02-2010

Jeżeli masz nieszczęście posiadać laptopa który po zainstalowaniu sterów binarnych Nvidia, nie chce poprawnie wyświetlać konsoli to dobrze trafiłeś, oto kilka rozwiązań tego problemu które krążą po sieci:

  1. Wykorzystanie uvesafb jako framebuffera – to pomogło „pokazać” konsolę na moim VR630-009PL. Jak ustawić uvesafb opisałem tutaj:

  2. Wykorzystanie normalnego framebuffera (opcja kernela VGA=ask pokaże dostępne tryby)

  3. Wyłączenie wszelkich framebufferów opcją VGA=normal.

  4. Dodanie opcji Nvreg_UseVBios=0 przy ładowaniu modułu „nvidia”: Jest kilka sposobów ustawienia zmiennej, ja utworzyłem plik /etc/modprobe.d/options i dopisałem do niego linijkę „options nvidia Nvreg_UseVBios=0” (oczywiście bez cudzysłowów). Po restarcie systemu można sprawdzić czy zmienna została ustawiona, komendą:

    cat /proc/driver/nvidia/registry | grep UseVBios
    
  5. Wykonanie punktu 4+użycie jakiegoś framebuffera (VGA=ask dla dostępnych trybów)

  6. Uaktualnienie BIOS'u laptopa do najnowszej wersji

Niestety są doniesienia że w niektórych wypadkach żadne z powyższych nie pomaga – w takim przypadku pozostaje tylko czekać na najnowsze sterowniki i mieć nadzieję że naprawią problem :(

OSnews Wykop Blip Flaker Kciuk Śledzik Facebook Identi.ca Twitter del.icio.us Google Bookmarks