Przejdź to tekstu

Debian "Stretch": szósta aktualizacja 'point release' (9.5 → 9.6)

W dniu 10. Listopada, 2018 roku ukazała się szósta, od oficjalnego wydania, aktualizacja, tzw. "point release", dla Stabilnej wersji, oznaczonej numerem 9. (nazwa kodowa "Stretch"). Uzupełnione zostały głównie poprawki związane z bezpieczeństwem, wydane do czasu tej aktualizacji wraz z kilkoma korektami dot. poważnych problemów w bieżącym wydaniu. Należy pamiętać, że owa aktualizacja nie jest kolejnym, nowym wydaniem systemu Debian.

Użytkownicy, którzy na bieżąco uaktualniają swój system (via security.debian.org), nie będą musieli aktualizować dużej ilości pakietów. Niemniej nowe, zaktualizowane obrazy płyt CD/DVD, które zawierają wszystkie zmiany wprowadzone w wyniku tej aktualizacji, dostępne są do pobrania (zob. Oficjalne obrazy - "stable" oraz odpowiednie dla wypróbowania systemu Debian - Obrazy "live".)

W wyniku tej aktualizacji, wprowadzono szereg aktualizacji bezpieczeństwa m.in. dla przeglądarek internetowych Chromium oraz Firefox-ESR, OpenJDK-8, Xorg Server, systemd czy jądra Linux etc., nie wspominając o zabezpieczeniach dotyczących np. mikrokodu procesora Intel (zob. pakiet intel-microcode), w którym dodano wsparcie dla nowo zdefiniowanego bitu Speculative Store Bypass Disable (SSBD). Jest on potrzebny do mitygacji luki Spectre v4 ("speculative store bypass"; CVE-2018-3639) ponadto zaimplementowano poprawki dla Spectre v3a ("rogue system register read"; CVE-2018-3640).

WAŻNE: Wsparcie dla w/w rozwiązań wymaga zaktualizowanego mikrokodu dla procesorów Intel. (Należy upwenić się, czy planowane jest wydanie nowej wersji mikrokodu dla procesora, z którego korzystamy). Kilka miesięcy temu wydano oświadczenie, w którym Firma Intel stwierdziła, że postanowiono nie udostępniać aktualizacji mikrokodu w celu ochrony przed `Spectre` oraz `Meltdown` w wielu starszych procesorach (lista dostępna jest w internecie)

Warto jednak zaznaczyć, że w przypadku Spectre v4 nowy, zaktualizowany mikrokod nie jest potrzebny w procesorach AMD.


Domyślna konfiguracja narzędzi służących do zarządzania pakietami (np. APT), pozwala na instalację aktualizacji etc., z wykorzystaniem głównych serwerów internetowych Debiana, ale istnieje możliwość modyfikacji pliku /etc/apt/sources.list w celu dodania tzw. serwera lustrzanego, znajdującego się bliżej lokalizacji użytkownika. Obszerna lista dostępna jest w tym miejscu: mirror/list. Serwery HTTP są generalnie szybsze niż FTP.

Przed aktualizacją systemu warto upewnić się, że mamy wystarczającą ilość miejsca na dysku twardym, ponieważ każdy pakiet potrzebny do instalacji, jest pobierany z sieci i przechowywany w katalogu /var/cache/apt/archives/. Należy więc sprawdzić, czy jest dostatecznie dużo miejsca na partycji systemowej /var (Oczywiście jeżeli została utworzona na etapie partycjonowania dysku, będącym niezbędnym krokiem podczas instalacji systemu.)

Narzędzie apt-get(8) może dostarczyć szczegółowych informacji o wolnej przestrzeni dyskowej. W tym celu należy skorzystać z polecenia (uruchomionego via sudo(8) bądź bezpośrednio z konta administratora, tj. root):

apt-get -o APT::Get::Trivial-Only=true dist-upgrade

Jeżeli nie ma wystarczającej ilości miejsca na dysku, apt-get(8) wyświetli odpowiednie ostrzeżenie, np.: E: You don't have enough free space in /var/cache/apt/archives/.

Przykładowy wpis, który należy dodać do pliku /etc/apt/sources.list, umożliwiający ww. aktualizację, może przyjąć następującą postać:

deb http://security.debian.org/ stable/updates main contrib non-free 

PRZYKŁAD: Nazwa dystrybucji, może być albo nazwą/aliasem kodu wydania (jessie, stretch, buster, sid) lub typem wydania (oldstable, stable, testing, unstable). Rozważmy taką sytuację: jeżeli użytkownik korzysta, na przykład, z systemu Debian 9.1 aka "Stretch", i nie planuje aktualizacji w chwili, gdy opublikowany zostanie Debian 10 aka "Buster" (kolejne Stabilne wydanie), winiem użyć "stretch"/"oldstable" w miejsce "stable", ponieważ od momentu, w którym wydana zostanie nowa edycja Stabilna, "Stretch" automatycznie zmieni się z wydania stable (stabilne) na oldstable (stare wydanie stabilne.) Wzór pliku sources.list, z uwzględnieniem obecnego wydania Stabilnego: Debian 9/Stretch.

Więcej informacji znajduje się w oficjalnym ogłoszeniu: Debian 9.6. Aktualizacje "point release" dla Stabilnej wersji, przygotowywane są przez tzw. Stable Release Managers (SRM) przy wsparciu Release Team. Debian 9.0 został pierwotnie wydany 17. Czerwca 2017 r.

SUPLEMENT (źródła, dodatki, informacje etc.)

  1. Point Release - informacje (zob.: szczegóły)
  2. APT - Debian Wiki
  3. source.list - Debian Wiki
  4. Lista repozytoriów (autor: azhag)

Dodany przez remi, 21 lis 2018 o 17:18

OSnews Wykop Blip Flaker Kciuk Śledzik Facebook Identi.ca Twitter del.icio.us Google Bookmarks


Komentarze (RSS):

  1. remi, 2018-11-21 17:25 [#]:

    Witam serdecznie.

    Chciałbym przeprosić wszystkich Was za tak długi okres, który wystąpił od czasu kolejnych wydań "point release", do momentu umieszczenia artykułów. Jeśli chodzi o wpis dot. Jessie/8.11, poprosiłem kolegę Mati75 o napisanie tego tekstu, ponieważ ja - na tamten czas - nie byłem do tego zdolny. I wywiązał się z tego znakomicie, po prostu niesamowicie. Bardzo Ci dziękuję, Mati.

    Tak, można by w tego rodzaju postępowaniu dostrzec ogromną nieodpowiedzialność, ale ostatnie miesiące...

    Przepraszam.

    P.S. Jeżeli według Was, jest już zbyt późno na publikowanie takich tekstów, to proszę je usunąć. Natomiast, odnośnie wspomnianych list procesorów, które nie będą miały zaktualizowanego mikrokodu, pod względem "Spectre & Meltdown", to na poniższej stronie można znaleźć listę (nie wiem, czy jest kompletna):

    ✗ https://www.rockpapershotgun.com/2018/04/05/intel-stop-meltdown-spectre-updates-for-old-cpus/


Dodaj komentarz jako gość lub zaloguj się.


Podpis: